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PREFACE 

This document describes the installation and operation of TASC Systems’ 
siteVIEW Enterprise distributed monitoring software. 

Hardware and software described in this document is subject to on going 
development and improvement. Consequently there may be minor 
discrepancies between the information in this document and the performance 
and design of the hardware and software. 

Refer to the siteCOMMANDER User Manual (document number 050-015-
0002) for detailed instructions and examples of use of the siteCOMMANDER. 

Before connecting any equipment to siteVIEW Enterprise, it is advised to read 
this manual in its entirety. 
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1. PRODUCT DESCRIPTION 

1.1. GENERAL DESCRIPTION 

siteVIEW Enterprise is a distributed monitoring software package designed to 
work in conjunction with TASC hardware monitoring products. Currently, only 
the siteCOMMANDER is supported.  

siteVIEW Enterprise is built with an easy to use graphical user interface that 
provides visibility into a network of siteCOMMANDERs. This simplifies the 
task of site monitoring by centralizing all site information and communication 
into a single software package.  

siteVIEW Enterprise allows for multiple simultaneous client connections to 
the siteVIEW datawarehouse. With this ability, it is possible to setup a group 
of operators or dispatchers, in one or multiple locations, to supervise and 
control siteCOMMANDERs in the network. 

siteVIEW Enterprise Components 

• Datawarehouse 

• Communication Server 

• User Interface 

1.2. siteVIEW Enterprise Key Features 

• Client / Server Architecture 

• Kenwood Fleetsync Protocol Integration 

• Multi – Protocol Communication Routing 

• Scheduled Polling and Log Retrieval 

• Site to Site Mapping 

• Custom Backgrounds 

• Drag and Drop Site Panels 

• Site Panel Grouping 

• Various Alarm Reporting Options 

• Simple Licensing Scheme  
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2. INTRODUCTION 

2.1. Client / Server Architecture 

siteVIEW Enterprise is based on a client/server software model with a central 
Datawarehouse for data storage.  

With siteVIEW Enterprise the server portion of the model is handled by the 
Communication Server. The Communication Server handles communication 
with one or more sites through a communication port on the PC. The 
Communication Server stores the data from communication with the device 
in the Datawarehouse. Multiple Communication Servers can use the same 
Datawarehouse to store information. 

The client, which is the siteVIEW User Interface, connects to the 
Datawarehouse and reads information stored by the Communication Server 
and displays it in an organized manner. Multiple clients can be connected to 
the same Datawarehouse at the same time and can view information for any 
Communication Servers connected to the Datawarehouse. 

The Alarm Manager is another service that accesses the Datawarehouse. 
The Alarm Manager determines when an alarm condition has occurred and 
notifies the operator through the user interface. 

2.2. siteVIEW Enterprise Licensing 

2.2.1. The Security Dongle 

The TASC siteVIEW Enterprise security dongle is a USB device, which 
contains: 

• One Server License 

• User Licenses 

• Feature Add-On Licenses 

Each Communication Server computer must have a security dongle in order 
for site monitoring to occur. The Communication Server reads the security 
dongle and retrieves the number of user licenses available and determines 
which feature add-ons are allowed.  

The number of user licenses, determines the number of operators that can 
sign into siteVIEW Enterprise User Interface at any one time. 
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Any Feature Add-on licenses present determine whether or not certain 
features in siteVIEW are enabled. The available Feature Add-ons are viewed 
in the About form, which can be viewed by selecting “Help->About TASC 
siteVIEW Enterprise Edition” from the main menu. 

Note: If the security dongle is removed from the computer, or if the 
Communication Server is stopped for any reason, site monitoring stops and 
any user licenses or Feature Add-on’s associated with the security dongle are 
disabled until the Communication Server restarts or the dongle is re-inserted. 
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3. STARTING THE USER INTERFACE 

To launch the siteVIEW Enterprise Edition user interface, double click on the 
siteVIEW Enterprise icon that the installation placed on the computer 
desktop. 

This can also be accomplished from the Windows start menu, select 
“Programs->TASC->siteVIEW Enterprise.” 

After launching siteVIEW Enterprise, one of two things should occur: 

• If siteVIEW is able to connect to a siteVIEW Enterprise 
Communication Server, a sign in form will appear. This is a typical 
scenario if the Communication Server is installed on the same 
computer as the user interface, or if the Communication Server 
connection was established previously. 

• If siteVIEW is not able to connect to a siteVIEW Enterprise 
Communication Server, the siteVIEW user interface will launch and at 
the bottom left corner of the application, the words “not connected” 
appear. 

 
Figure 1 - siteVIEW Enterprise User Interface Icon 

 
Figure 2 - User Interface Sign In 

 
Figure 3 - User Interface - Not Connected to Datawarehouse 
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To connect to a communications server, siteVIEW user interface must be 
connected to the same Datawarehouse the Communication Server is 
connected to. To connect to a Datawarehouse, select “Connect->Connect to 
Datawarehouse” from the main menu and you will be presented with an open 
file form. 

Navigate to a siteVIEW Enterprise Datawarehouse and select open. After 
selecting “Open”, the sign in form will appear. The default Datawarehouse is 
created automatically during the installation of the Communication Server.  

Note: Ensure you have the proper security rights to access the Datawarehouse 
file. 

Once the sign-in form appears, sign in using a valid username and 
password. When signing in to siteVIEW for the first time, use the username 
svadmin with password siteview. The svadmin is an administrator account 
with full rights to every part of siteVIEW Enterprise. 

Note: To ensure proper security, change the svadmin password during the first 
sign in 

 

 
Figure 4 - Open Datawarehouse Form 

 
Figure 5 - Selecting Datawarehouse 
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4. THE GRAPHICAL USER INTERFACE 

The TASC siteVIEW Enterprise Edition user interface consists of a main 
application window that is divided into several sections 

• Tree View - A tree view of the nodes in a network  

• Main Menu – Contains all available menu options 

• Toolbar – Quick access to daily functions 

• Alarm Panel – Detailed listing of all alarms 

• Site Panel – Graphical display of sites or network 

• Panel Component – Interactive elements in the network 

• Status Bar – Real time program information 

• Communication Panel – Listing of network communications 

 

Figure 6 - siteVIEW Enterprise User Interface 
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4.1. Site Navigation Tree 

The Site Navigation Tree is a logical representation of a network of 
monitoring devices (ie. siteCOMMANDER), which are capable of reporting 
input and output states to siteVIEW through a gateway device and into a 
communication port (COM port) at the Communication Server. 

The first level nodes of the Site Navigation Tree represent Communication 
Servers that are connected to the Datawarehouse. The second level nodes 
of the tree represent the communication port(s) on the Communication 
Server. The communication ports are used for communicating directly with 
the gateway device, which in turn communicate with the remote monitoring 
devices. The third level of tree nodes represents the physical device. 

Right clicking on one of the three node levels (server, COM port, device) 
allows quick access to menu options, by displaying a context menu that 
pertains to the selected node. 

Left clicking on a node causes the site panel to display a graphical 
representation of all nodes beneath the selected node. 

4.2. Main Menu 

The main menu allows access to configuration and monitoring of the tree 
nodes. Some menu items change depending on the node selected, and also 
depending on the user’s security rights (see Section 5.1). 

4.3. Tool Bar 

The toolbar allows quick access to some menu options 

• Hide/Show Site Navigation Tree 

• Perform manual poll of siteCOMMANDERs 

• View logs 

 
Figure 7 - Toolbar Buttons 
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4.4. Alarm Panel 

The alarm panel displays a list of alarms that have not been cleared at the 
remote site. Each alarm item in the alarm panel has the following information: 

• Port & device name of the alarm and the last time the alarm status 
changed 

• Auto-find button 

• Alarm status 

• Alarm severity and the name of the I/O where the alarm condition 
occurred 

• Running status of the alarm monitor 

The auto-find button appears as a square button with a question mark in the 
center. Selecting the auto-find button causes the corresponding device node 
to be selected on the Tree View and for the corresponding panel to be 
drawn. 

Double clicking on an alarm shows more detailed information about the 
selected alarm and allows the user to acknowledge and clear the alarm. 

When an alarm is active and unacknowledged, the alarm will flash. Minor 
alarms flash yellow, major alarms flash orange and critical alarms flash red. 

By default, when an alarm is cleared, it no longer shows in the alarm panel. 
However, by selecting “View->Show Cleared Alarms” from the main menu, 
you may show or hide cleared alarms. 

 
Figure 8 - Alarm Panel Components 
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4.5. Site Panel 

The Site Panel displays a graphical representation of the currently selected 
tree node. This provides simplified visibility in networks of 
siteCOMMANDERs. The panel’s size, background image, component 
placement, and color can all be configured. 

4.6. Panel Components 

The Site Panel is made up of images, text and Panel Components. Panel 
Components are interactive elements that allow the operator to navigate as 
well as monitor and control various areas of their network.  

At a sever node, Panel Components represent the available and configured 
COM ports that are accessible on the network. 

At a COM Port node, Panel Components represent the available and 
configured devices (siteCOMMANDERs) accessible on the network. 

At a device node, Panel Components represent the specific physical inputs 
and outputs available to a particular device. 

4.7. Status Bar 

The status bar is used to display various messages to the user. 

• Datawarehouse connection status and path  

• Current signed in user 

• Component dimensions in pixels 

• Current date and time 

4.8. Communication Panel 

The communication panel contains recent network communication traffic and 
the following details pertaining to those transactions: 

 
Figure 9 - Status Bar Components 
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• Name of COM port and device the communication pertains to and the 
time when the communication request occurred 

• Cancel transaction button 

• Communication transaction status 

• Communication transaction command and subcommand 

When a new communication transaction is added to the communication 
panel, any transactions that are older than 15 seconds and are no longer 
processing, are removed from the communications panel. 

Output control traffic is considered a special case. By updating an output a 
user either turns on or turns off that output. The output that is affected and 
the state that it is being set to are displayed next to the command and 
subcommand. 

 
Figure 10 - Communication Panel 

 
Figure 11 - Outputs Update Communication 
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5. USER ADMINISTRATION 

5.1. Managing User Accounts  

To create, modify or delete siteVIEW Enterprise user accounts open the user 
administration form, which can be viewed by selecting “Connect->Accounts-
>User Administration” from the main menu. 

 The following tasks may be performed using the user administration form: 

• New user accounts may be added 

• User names, usernames and passwords may be altered 

• User accounts may be enabled or disabled 

• Security rights may be altered 

• Existing users may be deleted from the system 

The following table lists the available security rights and the access 
associated with each type: 

 

 

 

 

 
Figure 12 - User Administration 

User 
Maintenance 

Device 
Configuration 

Panel 
Layout 

Alarm 
Control 

Manual 
Polling 

Output 
Control 

View Only None Read Read Read Read Read 
User None Read Read Read/ Write Read/ Write Read/ Write 
Power 
User 

None Read/ Write Read/ Write Read/ Write Read/ Write Read/ Write 

Admin Read/ Write Read/ Write Read/ Write Read/ Write Read/ Write Read/ Write 

Figure 13 - Security Level Matrix 
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5.1.1. Changing An Account Password 

A user can change their account password through the  “Change Password” 
form by selecting “Connect->Accounts->Change Password.” 

5.1.2. Forced User Sign Out 

In the case of a power failure or a system crash/reset, siteVIEW Enterprise 
may not get a chance to properly sign users out of the system. Also, there 
may be times when an operator(s) needs to be forcibly signed out of the 
system.  

In either case, operators may be forced out by anyone who has more 
security rights than they do or operators may sign themselves out. To view 
users that are currently signed in, type in a valid username and password at 
the sign in prompt, and select the “Users” button. 

This will open the “Current Users” form, with a list of users that are currently 
signed in, the computer that the user signed in from, and the date and time 
the he or she signed in.  

To sign a user out, select the user from the list of currently signed in users 
and select “Sign out”. 

 
Figure 14 - Changing Your Password 

 
Figure 15 - User Sign In Form 

 
Figure 16 - Current Users 
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6. SYSTEM CONFIGURATION 

The entire siteVIEW system is represented in two ways: it is represented as 
a logical tree, which is referred to as the Tree View, and as a graphical panel, 
which is referred to as the Site Panel. Items in the Tree View are referred to 
as nodes. 

When a node on the tree is selected, menu options pertaining to that node 
are accessible through both the main menu, which is located at the top of the 
User Interface, and the context sensitive popup menu, which can be 
accessed by selecting a node with the mouse and then performing a right 
mouse click. This document will explain how to configure siteVIEW using the 
main menu, but the same functionality can be accessed using the context 
specific popup menu. 

The Tree View displays a list of Communication Servers, the COM ports in 
use by the Communication Server and the devices that are monitored 
through the COM port(s). Main menu items pertain to the selected node. 

 

6.1. The Communication Server 

The Communication Servers, which are connected to the system, are visible 
in the Tree View. To view information pertaining to a particular 
Communication Server, select the desired node in the Tree View and then 
select “Edit->Properties” from the main menu. This launches the server 
details form. 

 

Figure 17 - Edit Menu 

 

Figure 18 - Sever Level Context Menu 



siteVIEW Enterprise User Manual  050-015-0016R01 

TASC Systems Inc. All Rights Reserved Page 21 of 59 

The server details form displays the machine name that the Communication 
Server resides on.  

By default, siteVIEW Enterprise uses the NetBIOS name of the server for the 
name of that server node in the Tree View. Using the alias field, a system 
applicable name can be used. The alias is the only item on the server details 
form that can be modified. 

The Communication Server software version, user licenses, and software 
add-ons are displayed in the Server Details form. 

 

6.2. Adding a New COM port 

Each Communication Server potentially has available COM ports, which can 
be used to monitor networks of hardware devices. To add and configure an 
available COM port for siteVIEW monitoring, select “Edit->New Port” from the 
main menu. This launches the COM port details form. 

In the COM port Details form, the name, description, COM port, protocol and 
communication timers are set. After entering the required information, select 
Ok or Apply and the new COM port will be added to the site navigation tree. 

 
Figure 19 - Server Details 
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6.2.1. COM Port Details 

To view and change information pertaining to a particular COM port on a 
Communication Server, select the desired COM port node on the Tree View 
and then select “Edit->Properties” from the main menu. This launches the 
Port Details form. 

Select a name for the COM port. The name will be how siteVIEW refers to 
this communication port throughout the application. 

The description properties of both the COM port and device detail forms are 
displayed when a user hovers the mouse above a Site Panel control that 
represents the COM port or device. 

The COM port field contains a list of communication ports available on the 
Communication Server.  

The refresh button forces the Communication Server to rescan its COM ports 
and refresh the COM port list. 

 
Figure 20 - COM Port Details 

 
Figure 21 - COM Port Example 
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The Protocol drop down field sets the protocol, which is used to 
communicate on the communication port. By default this protocol is set to 
BNMap. Other protocols are available as Add-On features from TASC. 

Two COM port timeout values exist. The packet timeout is the time the 
Communication Server will wait for a reply after transmitting a communication 
packet to a device. When the Communication Server is receiving a response 
packet, the packet bytes are received one at a time. The byte timeout is the 
time in which the Communication Server should wait between packet bytes, 
before deciding the packet has failed.  

By increasing the packet timeout and the byte timeout, siteVIEW is more 
likely to receive a packet. If siteVIEW needs to frequently retry packet 
transmissions, it is possible that one or both of these timeout values needs to 
be increased. If these timeout values are too high, siteVIEW communication 
may seem to take an unusually long time. Achieving the correct balance of 
timing values ensures that packets are handled efficiently. 

6.3. Adding a New Device 

Each Communication Server COM port is capable of communicating to a 
network of hardware devices. To add and configure a device for siteVIEW 
monitoring, first highlight the COM Port that connects the network of 
hardware devices to the Communication Server and select “Edit->New 
Device” from the main menu. This launches the Device Details form. 

 
Figure 22 - COM Port Element 
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First, the device details form will display the device description page. Enter 
the device name and description and select the next button to proceed. The 
device name chosen will be used by siteVIEW to make reference to the 
device. The description appears when a user hovers over the Site Panel 
control that represents the device. 

After entering the device name and description (optional), select the Next 
button to continue to the device communication configuration. The correct 
device COM port, module type and address must be selected in order for 
proper communication to occur. The device COM port is the communication 
COM port on the device that siteVIEW will attempt to communicate to. The 
module type and address specify which device to communicate with on the 
selected device COM port. 

 
Figure 23 - Creating a New Device 

 
Figure 24 - New Device Communication Properties 
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Sometimes it may be required to configure a device before placing the device 
at a site. A device can be configured locally by connecting the device directly 
to the Communication Server COM port and then selecting “Edit->Configure 
Local Device” from the main menu. This menu item is only available if a COM 
port tree node is selected. The local connection will attempt to communicate 
to a device on the selected server COM port.  

Configuring a device locally allows a user to configure communication 
features on the device that are not available otherwise. A device configured 
through a local connection does not appear on the site navigation tree, and is 
no longer accessible once the form is closed. 

6.3.1. Device Details 

After communication with a device has been successfully established, 
additional device configuration is made available. Selecting “Edit-
>Properties” from the main menu opens the device details form. The device 
details form provides the ability to configure a device.  

The device details form has multiple tabs. The available tabs may differ from 
device to device. Depending on the device’s firmware version, the available 
siteVIEW add-ons, and the type of device. Currently, the only device type 
supported by siteVIEW is the TASC siteCOMMANDER. See Appendix A for 
information on how to configure a siteCOMMANDER using siteVIEW 
Enterprise. 

WARNING: Making configuration changes to a device will cause the device to 
restart its firmware. As a result the device outputs will turn off. This could 
unintentionally activate/deactivate equipment located at the remote site 
without warning. It is the customer’s responsibility to ensure personnel or 
property is not damaged.  

6.4. Site Panel 

Each server, COM port and device has a panel associated with it. The panel 
contains controls that graphically map out the items available at the server, 
COM port or device. A server’s panel contains controls that represent COM 
ports, a COM port’s panel contains controls that represent devices, and a 
device’s panel contains controls that represent the device’s inputs and 
outputs. Performing a left mouse click on a panel control that represents a 
COM port or a device causes siteVIEW to display the panel for the selected 
COM port or device, essentially traversing the Tree View. Performing a left 
mouse click on a panel control that represents an output causes siteVIEW to 
turn on or turn off the associated output. Panel controls that represent device 
inputs serve as visual indicators of the inputs real life state. 

A user can modify the layout and appearance of the panel and the panel 
controls to give more meaning to the panel. 
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6.4.1. Background Properties 

The Site Panel background properties form can be modified in the Panel 
Details form, which is opened by selecting “Edit->Site Panel->Properties” 
from the main menu. The Panel Details form pertains to the currently 
displayed panel. 

The panel height and width affect the total size of the panel. This can be 
different from the actual height and width that the user sees. The panel 
height and width can be set larger or smaller than the actual viewable area of 
the PC screen. 

An image may be set as the panel background by selecting it from the list. 
When an image is selected, a preview of the image is shown in the picture 
box above the image list. To add an image to the list, select the Browse 
button, navigate to the desired image file and select ok. The Rename and 
Delete buttons rename and delete a selected image on the image list. 

The mode setting determines how the background image will be fit into the 
background.  

Color sets the panel background color. 
 

6.4.2. Panel Control Properties 

There are several types of panel controls. Individual panel controls may be 
customized to give the control more meaning. Panel controls represent COM 
port connections to sites, devices, contact inputs, analog inputs, temperature 
inputs and outputs. In most cases it makes sense to represent sites and 
devices by a boolean push button, contact inputs and outputs only have two 

 
Figure 25 - Background Properties 
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states and so they are best represented by a visual on or off using a boolean, 
and analog and temperature inputs have ranges and are best represented by 
knobs and slides. 

Selecting “Edit->Site Panel->Unlock Panel” from the main menu unlocks the 
currently displayed panel and allows the individual panel controls to be 
modified. While a panel is unlocked, the normal functionality of the panel 
controls ceases. Selecting a panel control opens a form that shows the panel 
control’s display properties. On the top of the panel control display properties 
form is a drop down field of all the controls that belong to the current panel. 
This drop down field, along with the previous and next buttons, is used to 
navigate through the panel controls. 

Certain panel control properties are common for all panel control types. 
Other properties are specific to a control type. The Disable User Control and 
confirmation properties are only available if the control it represents is an 
output. When the confirmation property is selected siteVIEW will prompt a 
user for confirmation if the user turns the output on or off. The Disable User 
Control option removes user control entirely. An administrator can set these 
settings accordingly 

The name of the panel control can be changed and shown or hidden using 
the Panel Control Display Properties form. A panel control can be made 
visible or hidden, or it can be deleted completely by selecting the delete 
button. Panel control colors, types and styles are all changed using the panel 
control display properties form. 

6.4.3. Panel Control Types 

Four panel control types are available in siteVIEW. The four panel control 
types are: boolean, slide, knob and display.

 
Figure 26 - Display Properties 
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Boolean 

 

Boolean control types are used to represent on and off, or are used as 
buttons. Properties specific to this control type include the off color, off text, 
off text color, on color, on text and on text color. 
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Figure 27 - Boolean Styles of Panel Controls 
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Knob (Knob) 

 

Dial (Dial) Horizontal Top 
Gauge 
(HTopGauge) 

 

Vertical Right 
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Figure 29- Knob Styles of Panel Controls 

Knob 

Knob control types are used to represent a range of values. Properties 

 
Figure 28 - Boolean Element Properties 
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specific to this control type include the foreground color, format string, axis 
caption, axis maximum and minimum, axis inversion, and the start and end of 
the arc of values. The knob control type is represented as an arc. 

The format string is discussed in more detail at the end of this section. The 
axis minimum and maximum specify the minimum and maximum values that 
the knob will display. The axis can be inverted so that the numeric scale is 
shown in reverse order. The arc start and end values determine the arc’s 
span. When the arc start and end values are set to –1 a default value is 
used. 

 

 
Figure 30 - Knob Properties 
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Slide 

Slide control types are like the knob control type since they are also used to 
represent a range of values. Properties specific to this control type include 
the fore color, format string, axis caption, axis maximum and minimum, axis 
inversion. The slide property is represented as a vertical or horizontal line. 
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Horizontal 1 (H) Vertical Pointer 
(VPointer) 
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Figure 31 - Slide Styles of Panel Controls
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The format string is discussed in more detail at the end of this section. The 
axis minimum and maximum specify the minimum and maximum values that 
the slide will display. The axis can be inverted so that the numeric scale is 
shown in reverse order. 

Display 

Display control types are used to display numeric values using a text string. 
Properties specific to this control type include the fore color and format string.  

The format string is discussed in more detail at the end of this section 

 
Figure 32 – Slide Style Properties 

 
Figure 33 - Display Style of Panel 

Controls 

 
Figure 34 - Display Style Properties 



siteVIEW Enterprise User Manual  050-015-0016R01 

TASC Systems Inc. All Rights Reserved Page 33 of 59 

6.4.4. Format String 

The following are examples of the variables and components that can be 
used to form a Format String. 

• . (decimal point) - specifies the beginning of the number within the 
label. Use # and 0 to the right of the decimal point to specify the 
precision. If you do not include a decimal point in the format string, a 
decimal point is assumed to be the first character in the format string 

• 0 - specifies the precision to the right of the decimal point. For 
example, ".#0" always produces two digits to the right of the decimal 
point, even when given an exact number such as 1.0 

• # - specifies the precision to the right of the decimal point. For 
example, ".##" produces up to two digits to the right of the decimal 
point. Thus, 1.0 produces 1, while 1.025 produces 1.03 

• e, E - specifies exponential notation. "E" specifies the capital letter, 
while "e" specifies the lowercase letter 

• *nn - scales labels. For example, ".*10" prints the value 1.0 as 10 

• +nn or -nn - offsets labels. For example ".+20" prints the value 1.0 as 
21 

• k - specifies symbolic notation. For the format string ".k", 1.0 prints as 
1, 1000 prints as 1k, and .001 prints as 1m 

• "text" - specifies to add text to the label. For example, '."V"' adds a V 
to the right of every label. Thus, 1.0 becomes 1 V 

• $, % - specifies to print these special characters 

•  

The following are two useful format string examples: 

• Celsius to Fahrenheit Conversion 

Using the equation ºF = (1.8) ºC + 32º to calculate the Fahrenheit value, a 
format string of *1.8 + 32 would be used and would result in the following: 

 
Figure 35 - Celcius to Fahrenheit Conversion 
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• Adding Text 

Using the previous example for converting Celsius to Fahrenheit, adding the 
string "°F" to the format string would become *1.8 + 32 "°F" and would result 
in the following: 

6.4.5. Adding Controls to a Panel 

It may be useful to have multiple components on a panel that represent the 
same input or output. For example, it may be useful to show an analog or 
temperature value as a dial or thermometer, and at the same time have a 
text representation of the same information.  

To add controls to a panel, first unlock the panel by selecting “Edit->Site 
Panel->Unlock Panel” from the main menu. While the Site Panel is unlocked, 
select “Edit->Site Panel->Add I/O” to open the “Add Panel I/O” form. Ensure 
the control is being added to the correct panel, then choose an input or 
output from the I/O list and select the add button. 

 
Figure 36 - Adding Text to Format String 

 
Figure 37 - Adding I/O to a Panel 
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The new control will appear in the top left corner of the panel. Move the 
control to the desired location and change the control properties as needed.  

It may be useful to have two panel controls representing the same output. By 
disabling user control on one of the outputs, the disabled control will show 
the actual device value. Whereas the control that allows user control would 
be out of sync with the device starting from the time a user changes the 
output until the device response is received. 

6.4.6. Panel Import and Export 

A panel may be exported to a file and re-imported later into the same panel 
or into a different panel. If any differences exist between two panels, those 
differences are ignored. For example, if a panel file that contains a 
temperature input control is imported into a panel with no temperature input 
to match, the resulting panel will not contain a temperature input control. The 
import and export functionality can be accessed by selecting “Edit->Site 
Panel->Import Panel” and “Edit->Site Panel->Export Panel” respectively. 

 

6.5. Alarm Conditions 

Each input and output can have alarm conditions associated with it. Alarm 
conditions set boundaries for inputs or outputs, allowing the user to be 
notified when the value goes outside this boundary. When the value is 
outside the alarm conditions boundary, the alarm has then been triggered 
and the user is notified. A user can then manage the alarm by taking 
necessary actions as defined by his procedures or the instructions 
associated with the alarm. 

 
Figure 38 - Panel Control Properties 
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6.5.1. Configuring an Alarm 

Selecting “Edit->Alarm Configuration” from the main menu opens the alarm 
configuration form. From this form a user can create new alarm, and delete 
or modify existing ones.  

When creating an alarm, ensure the server, COM port, device and device I/O 
are selected correctly. Changes made to the alarm configuration form do not 
take affect until the update button is selected or add is selected while 
creating a new alarm condition. 

The alarm severity is used to place importance and priority on alarms.  Three 
alarm severity options exist: Minor, Major and Critical. Minor alarms are the 
least severe and Critical alarms are the most severe.  

An alarm can be enabled or disabled by changing the Enabled option. 

The type and number fields indicate the input or output the alarm condition 
applies to.  

The alarm conditions for a contact input or an output have only two choices 
and that is On or Off. In other words an alarm can be set to trigger when the 
input or output is on or when it is off. 

The analog or temperature input alarm conditions are based on the low and 
high set points of the device’s input, which are configured through the device 
details form and displayed as read-only fields in the alarm configuration form. 
When an input’s value crosses one of its set points, the device then notifies 
siteVIEW of the change. The alarm can be triggered if the input’s values go 
above a set point, below a set point or the set point change can be ignored.  

The alarm details are useful for providing instructions to the user when the 
alarm occurs. 

 
Figure 39 - Alarm Configuration Form 
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The list on the bottom of the alarm configuration form displays alarm 
conditions. Select an entry from the list to see the alarm condition details. If 
an alarm condition does not appear on the alarm condition list, ensure the 
filter is selected correctly. 

6.5.2. Alarm Sounds 

The sound field displays the name of a sound file to play on the event the 
alarm is triggered. If an alarm is selected the sound interval can be changed. 
The sound interval determines the length of time siteVIEW will wait before 
replaying the sound file. 

Selecting the select button beside the sound field opens the select sound 
form. From this form a user can select a sound file to play when the alarm 
condition it is associated with is triggered. 

From the select sound form, sound files may be deleted, renamed or 
sampled, and new sound files may be loaded. siteVIEW is capable of playing 
most common sound file types including wave (.wav), midi (.mid), mpeg layer 
3 (.mp3) and windows media audio (.wma). 

6.6. Automated Polling 

Automated Polling is used to check the status of selected 
siteCOMMANDERs within the network at scheduled intervals. This is used to 
ensure that conditions at remote locations remain within acceptable 
parameters. 

Selecting “Edit->Polling Configuration” from the main menu opens the polling 
configuration form. From this form a user can create polling schedules, and 
delete or modify existing ones.  

Changes made to the polling configuration form do not take effect until 
Update is selected after making changes to an existing polling schedule or 
add is selected while creating a new polling schedule. 

 
Figure 40 - Alarm Sound Properties 



siteVIEW Enterprise User Manual  050-015-0016R01 

TASC Systems Inc. All Rights Reserved Page 38 of 59 

A scheduled poll tells siteVIEW to communicate with a device at a specified 
time. The type of communication depends on the type selected. Available 
scheduled poll communication types are: 

• DeviceStatus: retrieves the device status. This ensures that siteVIEW 
has not lost communication with the device. Also it allows siteVIEW to 
detect if any device configuration has changed. If a change in device 
configuration is detected, siteVIEW will automatically download the 
new configuration settings. 

• AllContactInputs: retrieves the contact input values. 

• AllTemperatureInputs: retrieves the temperature input values. 

• AllOutputs: retrieves the output values. 

• AllAnalogInputs: retrieves the analog input values. 

• MMaxLogCount: retrieves the min/max log count. If the returned value 
is more than zero, siteVIEW will automatically download and clear the 
min/max log. 

• SampleLogCount: retrieves the sample log count. If the returned value 
is more than zero, siteVIEW will automatically download and clear the 
sample log. 

• StaticMMaxLog: retrieves and then clears the current min/max values. 

• RTCRamLog: retrieves values stored in the real time clock (RTC) 
random access memory (RAM). The data logger timers are stored in 
the RTC RAM. 

A scheduled poll has an interval. This interval specifies how often the 
scheduled poll is to occur. An interval of every two hours will cause the 
scheduled poll to occur every two hours for the selected days, starting from 
the start date and ending on the end date. The scheduled poll end date can 
be set to never end by removing the end date option. If the selected interval 
is in minutes or hours, an end time may be specified. If an end time is 

 
Figure 41 - Polling Configuration Form 
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specified but no end date is specified, the scheduled poll will occur 
indefinitely but only between the specified times each day. An end time 
cannot be specified if the time interval specified is day, week, month or year. 

Scheduled polls without the enabled option selected will not occur, but can 
be re-enabled by selecting the Enabled option and then selecting Update. 

In order for a scheduled poll to occur, at least one siteCOMMANDER must 
be assigned to the scheduled poll. There are two list-boxes in the scheduled 
poll form, each showing a list of Communication Servers, along with the 
Communication Server’s COM ports and the devices connected to those 
COM ports. The Excluded list contains devices that will not be included in 
this scheduled poll; whereas the Included list contains devices will all be 
polled at the scheduled time. After including or excluding devices in the 
scheduled poll the update button must be selected in order to Update the 
schedule poll. 

Deleting a scheduled poll permanently deletes the scheduled poll for all 
devices associated with the scheduled poll. 

The list on the bottom of the scheduled polling configuration form lists 
existing scheduled polls. Clicking on an entry in the list shows the schedule 
details. If a scheduled poll does not appear on the scheduled poll list, ensure 
the device filtering options are selected correctly. 

6.7. Site Mapping 

Selecting “Edit->Site Mapping Configuration” from the main menu opens the 
site mapping configuration form. From this form a user can map outputs to 
any other input or output which is monitored by siteVIEW. The site mapping 
configuration form is also used to delete or modify existing mappings.  

Changes made to the site mapping configuration form do not take affect until 
update is selected after making changes to an existing output mapping or 
add is selected while creating a new output mapping. 

An output mapping tells siteVIEW to turn on or turn off a specified output 
based on the result of some other input or output in siteVIEW.  

 

 

 

 

 

 

 



siteVIEW Enterprise User Manual  050-015-0016R01 

TASC Systems Inc. All Rights Reserved Page 40 of 59 

 

WARNING: Site Mapping cannot occur if siteVIEW loses its connection to the 
mapped device. If the target device is unreachable then no output event can 
occur. 

The input condition is specified for a specific server, COM port, device and 
input or output on that device. When the input or output condition occurs, 
siteVIEW is then to take the specified output action. An input condition can 
occur when an input or output is turned on or off, or an input condition can 
occur when an analog or temperature value is less than or greater than one 
of its set points. 

The site mapping condition form allows a user to modify, delete and enable 
or disable site mappings. 

The list on the bottom of the site mapping configuration form displays site 
mappings. Select an entry from the list to see the site mapping details. If a 
site mapping does not appear on the site mappings list, ensure the filter is 
selected correctly. 

 
Figure 42 - Site Mapping Configuration Form 



siteVIEW Enterprise User Manual  050-015-0016R01 

TASC Systems Inc. All Rights Reserved Page 41 of 59 

7. MONITORING AND CONTROLING DEVICES 

Once the siteCOMMANDER devices are configured, they are then ready for 
monitoring and control. Monitoring and control using siteVIEW includes 
viewing the current status of devices, controlling device outputs and 
responding to alarms. 

siteVIEW does not exit completely when the siteVIEW user interface is 
closed (by selecting the close button in the top right corner of the main 
application form). Instead siteVIEW is minimized to the system tray. To exit 
the siteVIEW user interface completely, select “Connect->Exit siteVIEW” 
from the main menu. Once siteVIEW is closed, the communication service 
and alarm monitor continue to function. Communication with the configured 
sites, auto polling, site mapping and new status information returned from the 
device all continue to occur even though the user interface has been closed. 

WARNING: Even though the User Interface may be closed, monitoring, alarm 
reporting, scheduled polling and Site Mapping continue to occur for the rest of 
the User Interfaces connected to the Datawarehouse 

7.1. Device Inputs and Outputs 

siteVIEW can monitor several types of inputs and output. Those inputs and 
outputs can be represented in different meaningful ways. 

Panel control outputs can be turned on and off, but inputs cannot be 
changed. Outputs may be controlled if the user has the required access 
rights. When controlling outputs, the value displayed on the panel will be 
different than the actual output value while the command is being sent. 
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7.2. Alarm Handling 

Alarm conditions pertain to input and output values. When an alarm condition 
occurs, an alarm is triggered and the siteVIEW user is notified in several 
ways. Visually, the affected input or output Panel Component will blink on 
and off, the associated navigation tree node displays an alert icon and an 
alarm is added to the alarm panel. 

WARNING: the 3DCommandOk and 3DToggleOnOff Boolean control styles do 
not blink during an alarm condition. 

 
Figure 43 - Site Panel Example 

 
Figure 44 - Alarm Pop-Up Notification 
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If siteVIEW is minimized when an alarm occurs, the siteVIEW system tray 
icon will display a blinking alert icon and an alarm popup screen is displayed 
above the siteVIEW system tray icon, in the bottom right area of the screen. 

If the triggered alarm has a sound file associated to it, the sound file will play 
while the alarm is active or until the user mutes the alarm sound. 

The alarm popup form displays a summary of active alarms. Whereas the 
alarm panel displays all active and inactive alarms that have not been 
cleared. Each entry of the alarm popup form and each entry on the alarm 
panel have a find button with a question mark on it. Selecting the find button 
navigates the user to the device where the alarm occurred, and the device 
panel is displayed. 

Each alarm entry on the alarm panel and alarm popup displays information 
about the input or output where the alarm has occurred. Performing a double 
mouse click on an alarm panel entry displays the alarm details form. 

The Alarm Details form gives details of the alarm location, the time the 
alarm’s status last changed and details about the alarm. The Details field is 
useful for providing instructions to a user in the event that the alarm is 
triggered. 

If an alarm has a sound file associated to it, selecting the mute button stops 
the sound from playing until the alarm has been triggered again. The snooze 
button causes the alarm sound to stop and not resume again until five 
minutes later. If within those five minutes the alarm condition ceases, the 
snooze is interrupted and the sound will not occur again until the next time 
the alarm is triggered. 

The status of the alarm is displayed in the status field. A user can change the 
status of the alarm by selecting an action and then selecting the Set button. 
Active alarms can be cleared or acknowledged. Acknowledging an alarm 
causes the alarm to remain in the alarm panel, but all other alarm indications 

 
Figure 45 - Alarm Details Form 
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stop. Clearing an alarm removes the alarm from the alarm panel completely. 
But selecting “View->Show Cleared Alarms” causes cleared alarms to be 
displayed on the alarm panel as well. 

Alarm panel entries have different colors based on the alarm severity and 
status. Critical alarms appear with a red background, major alarm 
backgrounds are orange and minor alarm backgrounds are yellow. When an 
alarm has become inactive or when an alarm is cleared, the alarm panel 
entry background turns grey. The background of an active alarm blinks when 
the alarm is neither acknowledged nor cleared. 

7.3. Manually Polling the Devices in the Network 

Options exist that allow a user to manually initiate a poll of the devices. This 
allows the operator to retrieve the current status of the siteCOMMANDER at 
any time. To perform a manual poll select one of the “Edit->Manual Poll” 
submenus. Selecting the manual poll button on the tool bar can access the 
same functionality. 

Selecting “Edit->Manual Poll->Status Refresh” causes siteVIEW to retrieve 
the status and I/O values of all devices under the currently selected node.  

For instance, if a Server node is selected then all COM Ports and their 
respective devices will be polled. 

If a COM Port Node is selected then all devices within that COM Port will be 
polled. 

If a device node is selected then only that particular device will be polled. 

A status refresh retrieves a device’s status and I/O values. A configuration 
refresh retrieves the device’s configuration settings. A full refresh performs 
the functionality of a status refresh and a full refresh combined. 

 

 
Figure 46 - Manual Poll Options 
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8. LOGGING 

Each time an alarm occurs, or an I/O value changes or communication with a 
device occurs, siteVIEW records the event in a log. This is known as 
siteVIEW logging.  

A device also has logging of its own. This kind of logging is referred to as 
device logging. 

 

 

Figure 47 - siteVIEW Logs 

The log viewer can be viewed by selecting “View->Logs” from the main menu 
or by selecting the logs button from the toolbar. 

The log viewer form displays log entries on the right and a list of log types on 
the left. From the main menu of the log viewer form a user can export, clear 
or refresh log entries. Logs are automatically archived to prevent the logs 
from becoming unmanageably large. A list of archived logs is shown on the 
bottom left of the Log Viewer. Select an archived log to view it in the Log 
Viewer. 

8.1. siteVIEW Logging 

Each time an alarm’s status changes an entry for the alarm is recorded in the 
alarms log. Each time communication occurs between siteVIEW and a 
device, the communication is recorded in the communications log. Each time 
an I/O value is returned from a device, an entry is recorded in the I/O values 
log that indicates this value. 
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8.2. Device Logging 

A device may be set up to perform logging locally. If device logging is 
enabled for a device, it can be manually retrieved or automatically retrieved 
by siteVIEW Enterprise by setting up an automated poll. To retrieve a 
device’s log manually, select the device’s node on the navigation tree and 
then select “Edit->Data Logger” from the main menu. This will open the 
device data logger form. 

The first time the device data logger form is opened for a device, most of the 
information will be unavailable. There are two refresh buttons on the device 
data logger form that allow a user to refresh the logger information. If the 
data logger is running, the data logger information will constantly change at 
the device and siteVIEW will not be aware of the changes without performing 
another refresh. 

A user can download the sample log or the min/max log and when the 
download has completed, siteVIEW automatically clears the log that was 
downloaded. Or a user can manually clear the log without downloading the 
values. 

The data logger can be stopped and started from the device data logger 
form. The time the logger was started is displayed in the field labeled start 
time. 

Several timers exist in the device Data Logger form. These values are not 
stored in the data logger and they cannot be automatically downloaded. The 
timers are only available for viewing through the device data logger form. The 
timers display the total accumulated time the carrier operated squelch (COS) 
was active and accumulated time the inputs were on. The last update time 
displays the last time these values were updated. 

8.3. Logging Properties 

You can access the Log Viewer Properties page by selecting “Action-
>Properties” from the Log Viewer menu. 
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8.3.1. Log Archiving 

By default logs available from the Log Viewer are automatically archived 
every Sunday at 3:00 am.  The log archiving interval is configurable from the 
Log Viewer Properties page.  

 

Figure 48: Log Viewer Properties 
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9. TROUBLESHOOTING 

9.1. Event Viewer 

TASC siteVIEW uses the Windows operating system’s event viewer to track 
when the Communication Server and alarm monitor stop and start. The event 
viewer is also used to track Datawarehouse connections, to track dongle 
information such as licenses and add-ons, and to track siteVIEW server 
application errors. 

To access the event viewer, select Administrative Tools from the Windows 
control panel. Under administrative tools, select event viewer. The TASC 
siteVIEW event log is specific to TASC siteVIEW Enterprise. 

The event viewer can be used to help troubleshoot problems with the 
security dongle and Datawarehouse connectivity problems. 

9.2. Solutions to Problems 

I cannot sign into siteVIEW because there are no licenses available 
 

• Look in the event viewer and ensure the Communication Server 
properly detected the dongle and connected to the Datawarehouse. 

• Ensure the siteVIEW user interface is connecting to the same 
Datawarehouse that the Communication Server is connected to. 

• It may be possible the Communication Server is not running for some 
reason. Restarting the computer that the Communication Server 
resides on should start the Communication Server. 

 

siteVIEW will not detect my dongle 
 

• Ensure the dongle is properly inserted into an available USB 
connection on the computer where the Communication Server 
resides. Do not remove the dongle at any time while the 
Communication Server is running. 

• If the dongle is properly inserted and siteVIEW still does not detect the 
dongle, remove the dongle and restart the computer. Once the 
computer has restarted then insert the dongle and allow the operating 
system to find and install any drivers it needs. Once the operating 
system has detecting the dongle, siteVIEW should function properly. 
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The Communication Server is not running 
 

• Restart the computer. This will force the Communication Server to 
start as well. 

 

The alarm manager is not running 
 

• Restart the computer. This will force the alarm manager to start as 
well. 

 

I cannot make changes to the system 
 

• Ensure the login user you are using has the appropriate rights to 
access the siteVIEW features you wish to use. 

 

siteVIEW is unable to make a connection to a device 

• Ensure the device addressing is correct, because otherwise siteVIEW 
will not be able to connect to the device. 

• Ensure the device is connected properly. 
 

siteVIEW tells me the COM port is already in use 
 

• Ensure no other applications are using a COM port that siteVIEW is 
expecting to use for monitoring. Once an application is closed and the 
COM port is freed up again for siteVIEW to use, select “Edit-
>Properties” for the COM port that had difficulties, and then select the 
refresh button to allow siteVIEW to resume monitoring on the COM 
port. 

 

I cannot connect to the Datawarehouse 
 

• Ensure the security rights, of the Datawarehouse you are trying to 
connect to and the folder it is located in, allow you access. 

 

I cannot establish a connection with a local device 
 

• Ensure the device is attached to the same Communication Server and 
COM port that you are using siteVIEW to connect with. 
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10. TASC SITECOMMANDER CONFIGURATION 

The TASC siteCOMMANDER is a hardware device that can be used in 
conjunction with siteVIEW Enterprise. The device has its own firmware 
configuration that can be changed either using it own configuration software 
(SCCU) or by using siteVIEW Enterprise. This section discusses how to 
change the siteCOMMANDER device settings. 

10.1. Description 

The description tab contains the name and description of the device. This tab 
is not available for a locally connected device. 

 

10.2. General 

The general tab contains read-only information about the device such as the 
device type, the device’s internal firmware version, extra device options 
available, the number of child modules attached to the device and the 
number of temperature sensors that are attached to the device. 

 

 
Figure 49 - Device Properties 
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10.3. Startup Options 

The startup options tab contains configuration that pertain only to the startup 
of the device. The startup delay is the length of time in seconds that the 
device will wait after starting, before it begins monitoring. The enable power 
save option causes the device to switch into low power mode. When the 
device is in low power mode, it will have a sleep time. At the end of each 
sleep interval, the device will wake up and check its status. The wake on 
COS option causes the device to wake up out of low power mode when it 
detects a carrier operated squelch from the ffsk module. 

 

 
Figure 50 - Device Properties - General 

 
Figure 51 - Device Properties - Startup Options 
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10.4. Communication 

Making changes to the communication form after the first communication has 
been established causes the communication configuration to be altered.  

The device COM port specifies the COM port the device is to use as its 
primary COM port. 

The module type of the device determines the role of the device. The 
following is a quick description of each mode: 

• Gateway: This mode is used on a single device to connect a network 
of siteCOMMANDERs to the siteVIEW Enteprise Communication 
Server.  

• Master: This mode is used in point-to-point or point-to-multipoint 
applications not involving siteVIEW products 

• Slave No Mapping: This mode is used for remote devices in siteVIEW 
and non-siteVIEW applications 

• Slave Input Mapping: This mode is used strictly for point-to-point or 
point-to-multipoint applications not involving siteVIEW products 

The COM port retry count decides how many times the device should send a 
message before giving up. The retry timeout determines how long to wait for 
a response after sending a packet. 

Serial port 2 and the FFSK port can only be changed when siteVIEW is in a 
local connection with the device. This is to ensure that siteVIEW does not 
lose connectivity with the device it is configuring. To configure serial port 2 
and the FFSK port siteVIEW must connect to the device locally. 

 

 
Figure 52 - Device Properties - Communication 
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10.5. Contact Inputs 

If enable event is selected for a contact input, the device will notify siteVIEW 
whenever the input is turned on or off. The off state specifies if the input is 
normally in the open state or if it is normally closed. The state that is 
specified as normal then becomes the off state of the device. 

The input mode can be set as normal or toggle. If normal is selected, the 
input is edged triggered. If toggle is selected, the input is triggered based on 
levels; the input will alter it state on alternating positive levels. 

An input can be set such that when the input is turned on, an output is turned 
on and when the input is turned off that same output is then turned off. The 
hold time specifies the amount of time the input must stay on before the 
output will be turned on or off. The local output specifies the output to be 
turned on and off. The output delay indicates how long the device should wait 
before turning on the local output. 

 
Figure 53 - Device Properties - FFSK Communication 

 
Figure 54 - Device Properties - Contact Inputs 
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The output action can be normal, set or reset. If the output action is normal, 
then the output turns on when the input is turn on and the output turns off 
when the input is turned off. If the output action is set, then the output is 
turned on when the input is turned on, but the output is unaffected when the 
input is turned off. Reset causes the output to be turned off when the input is 
turned on, but is unaffected when the input is turned off. 

10.6. Analog Inputs 

 

If enable event is selected for an analog input, the device will notify siteVIEW 
whenever the input crosses either the low or high set point voltage.  

The range indicates the analog input type that is connected to the device. If 
this value is not set correctly, siteVIEW may report invalid analog input 
information. 

An analog input can be set such that when the input voltage goes above the 
high set point, an output is turned on and when the input voltage goes below 
the low set point an output is then turned off. The invert set points option 
causes the event to occur when the voltage goes below the high set point 
voltage, or above the low set point voltage. 

The hold time specifies the amount of time the analog input must stay above 
or below the set point before the output will be turned on or off. The local 
output specifies the output to be turned on and off. The output delay 
indicates how long the device should wait before turning on the local output. 

 

 

The siteCOMMANDER module cannot accept voltages on its inputs that are 
negative with respect to ground. Application of negative voltages to the digital 
and analog inputs will damage the module. 

 
Figure 55 - Device Properties - Analog Inputs 
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The module provides fixed input ranges of 0-2.56V, 0-5.12V, 0-25.0V and 4-
20mA depending on jumper settings. Four user ranges of X2, X4, X10 and 
X20 can also be programmed based on a 5 V internal reference. 

10.6.1. Analog Input Jumper Configuration 
 

Each analog input may be set to a different range via jumpers J1 to J16 in 
conjunction with the SCCU utility. Each analog input has two jumpers noting 
that the order of jumpers is reversed, i.e. J1 & J2 correspond to the highest 
analog input. 

 

 

 

Analog Jumper block 
8 J1 / J2 
7 J3 / J4 
6 J5 / J6 
5 J7 / J8 
4 J9 / J10 
3 J11 / J12 
2 J13 / J14 
1 J15 / J16 

Figure 56 - Device Properties – Analog Jumper Configuration 
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Each pair of jumpers configures one of four programmed ranges.  

 

When a range is selected via the jumper block, the corresponding range 
must also be set in the analog configuration pages for the device. 

 

Figure 57 - Device Properties – Photo of siteCOMMANDER Analog Jumpers 

Analog 0-2.56V 
0-5.0V 
User Range 

0-25V 4-20mA 

1 J16-1 to J16-2 
J15 Out 

J16-3 to J16-2 
J15-1 to J15-2 

J16-1 to J16-2 
J15-2 to J15-3 

2 J14-1 to J14-2 
J13 Out 

J14-3 to J14-2 
J13-1 to J13-2 

J14-1 to J14-2 
J13-2 to J13-3 

3 J12-1 to J12-2 
J11 Out 

J12-3 to J12-2 
J11-1 to J11-2 

J12-1 to J12-2 
J11-2 to J11-3 

4 J10-1 to J10-2 
J9 Out 

J10-3 to J10-2 
J9-1 to J9-2 

J10-1 to J10-2 
J9-2 to J9-3 

5 J8-1 to J8-2 
J7 Out 

J8-3 to J8-2 
J7-1 to J7-2 

J8-1 to J8-2 
J7-2 to J7-3 

6 J6-1 to J6-2 
J5 Out 

J6-3 to J6-2 
J5-1 to J5-2 

J6-1 to J6-2 
J5-2 to J7-3 

7 J4-1 to J4-2 
J3 Out 

J4-3 to J4-2 
J3-1 to J3-2 

J4-1 to J4-2 
J3-2 to J3-3 

8 J2-1 to J2-2 
J1 Out 

J2-3 to J2-2 
J1-1 to J1-2 

J2-1 to J2-2 
J1-2 to J1-3 

Figure 58 - Device Properties – Analog Jumper Ranges 
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10.6.2. User Ranges 
 

The user may select one of four external analog ranges by supplying an 
external ‘potential divider’ resistor network. 1% tolerance resistors should be 
used. To configure an analog input for an externally supplied resistor 
network, set the jumpers the same as for 5V. 

The following table shows suggested external resistor network values for the 
user range settings. 

10.7. Temperature Inputs 

If enable event is selected for a temperature input, the device will notify 
siteVIEW whenever the input crosses either the low or high set point voltage.  

The device may have zero to eight temperature inputs present. The present 
indicator lets the user know which input is available for configuration. 

A temperature input can be set such that when the input temperature goes 
above the high set point, an output is turned on and when the input 
temperature goes below the low set point an output is then turned off.  

The hold time specifies the amount of time the temperature input must stay 
above or below the set point before the output will be turned on or off. The 
local output specifies the output to be turned on and off. The output delay 
indicates how long the device should wait before turning on the local output. 

2 x 5V = 10V 4 x 5V = 20V 10 x 5V = 50V 20 x 5V = 100V 
Ra = 10KΩ 
Rb = 10KΩ 

Ra = 30KΩ 
Rb =10KΩ 

Ra = 90KΩ 
Rb = 10KΩ 

Ra = 190KΩ 
Rb = 10KΩ 

Figure 59 - Device Properties – Suggested External Resistor Values 

 
Figure 60 - Device Properties - Temperature Inputs 
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10.8. Outputs 

The off state specifies if the output is normally in the open state or if it is 
normally closed. The state that is specified as normal then becomes the off 
state of the device. 

The output mode can be set as latch or pulse. If latch is selected, when the 
output is turned on it is left on until the output is turned off again. If pulse is 
selected, when the output is turned on the output only stays on for the length 
of times specified by the pulse width. 

 

10.9. Device Logging 

<Need a description of log air time> 
 

The log roll over determines what the device will do when its log file becomes 
full. If log roll over is enabled, the device will overwrite the oldest log entry to 
create a new one. If log roll over is not enabled, the device will stop logging 
when the data logger buffer is full. 

Selecting power up run ensures the data logger starts automatically 
whenever the device starts up. 

 
Figure 61 - Device Properties - Outputs 
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The data logger logs sample data at selected intervals and it logs min/max 
data for selected inputs. The buffer allocation determines how much of the 
data logger buffer is allocated to each data logger type. 

The enabled option determines if the selected input is included when logging. 
The analog and temperature inputs have a log thresholds option that will 
cause the data logger to log each time the input’s value crosses its high or 
low set point. The input qualifier decides that the input value can only be 
logged when the specified input qualifier is on. 

The contact inputs can be logged each time they are turned on or off, or they 
can be logged as accumulative on times. 

 

 
Figure 62 - Device Properties - Device Logging 


